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PKB Error Responses
PKB Error Responses
Work In Progress
These can be seen in the “PKB Outbound - Partner” Channel in Mirth, with the subset relating to identifiers etc. also being present in “PKB Outbound - Research”.
Parsing or validation error: Ambiguous patient IDs provided
Cause:
We have sent PKB a HL7 message with more than one NHS Number in the PID Segment. Within the PKB database these identifers are present on different PKB accounts - hence it doesn’t know which we are attempting to update.
Solution:
ukrdc.services.exceptions.PatientIdentifierNotFoundError: Patient not Found
Cause:
The XML request sent to our internal PKB web service contains a PID which no longer exists in the database.
Unexpected error while processing (support code na20240422100839): Error while creating institute user-1695207285|
Unexpected error while processing (support code na20240422080121): Unable to send carer email com.pkb.exception.MailException: Unable to send message=[ACTIVITY_NOTIFICATION_TO_CARER_FOR_PATIENT]
Received Error Response from HTTP server.
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